Attack on IPs - 51.254.105.225 and 164.132.10.28

Incident Report for SeekaHost

Resolved

Mitigation has been completed for both IPs, and the services are back to normal
Posted Aug 30, 2026 - 05:26 UTC

Monitoring

IP - 51.254.105.225 and 164.132.10.28 under mitigation.
Posted Aug 29, 2026 - 06:18 UTC
This incident affected: Seekahost.com (Hosting servcies).