DDOS Attack on IP 158.69.2.73

Incident Report for SeekaHost

Resolved

This incident has been resolved. IP and websites are accessible now
Posted May 09, 2026 - 08:28 UTC

Monitoring

IP 158.69.2.73 is under mitigation due to an attack
Posted May 08, 2026 - 07:44 UTC
This incident affected: Seekahost.com (Hosting servcies).