Srv314.seekahost.net

Incident Report for SeekaHost

Resolved

Our server team have replaced the conductor and monitored the website for a while. Both the server and the websites are functioning smoothly now.
Posted Dec 10, 2025 - 12:42 UTC

Identified

Changing the electric conductor
Posted Dec 10, 2025 - 11:28 UTC
This incident affected: Seekahost.com (Hosting servcies).