DDOS attack on IP 51.161.92.253

Incident Report for SeekaHost

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 15:41 UTC

Update

Mitigation has been completed for the IP address, and the services are back to normal.
Posted Sep 09, 2026 - 15:40 UTC

Monitoring

IP is currently under mitigation Process
Posted Sep 07, 2026 - 05:01 UTC
This incident affected: Seekahost.com (Hosting servcies).