DDOS attack

Incident Report for SeekaHost

Resolved

All the websites and services are operational.
Posted Aug 29, 2025 - 05:50 UTC

Update

The IP has now been reverted to the server and is being monitored by our server team.
Posted Aug 01, 2025 - 03:24 UTC

Monitoring

IP 5.135.14.8 has been identified as a DDoS attack, which is currently under mitigation. Our server team is monitoring the IP.
Posted Jul 23, 2025 - 09:50 UTC
This incident affected: Seekahost.com (Hosting servcies).