SRV301 - Server Down

Incident Report for SeekaHost

Resolved

Our server team have fixed the issue and the server is performing well.
Posted Sep 09, 2025 - 22:18 UTC

Investigating

We are currently investigating the issue
Posted Sep 09, 2025 - 12:15 UTC