Maintenance is fully completed on the SeekaHost India Client Area Portal.
Posted Jul 25, 2025 - 04:38 UTC
Identified
Date: 25-JULY-2025 Time: 9:00 AM to 10:30 AM IST Expected Impact: Seekahost India Client Area Portal Alone will remain inaccessible. All your services will be active. Maintenance Purpose: Interface is getting updated with New Features.
Posted Jul 25, 2025 - 03:01 UTC
This incident affected: Seekahost.in (Support Service).