Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2026 - 03:30 UTC
Scheduled
We will be undergoing scheduled maintenance during this time. An interruption of service of approximately 1h is to be expected for the replacement of the network equipment.
Posted Jan 24, 2026 - 08:06 UTC
This scheduled maintenance affected: Seekahost.com (Hosting servcies) and Seekahost.co.uk (Hosting servcies).