Server Down

Incident Report for SeekaHost

Resolved

Server issue resolved completely and website is loading fine
Posted Jul 23, 2025 - 15:35 UTC

Monitoring

Our server team has fixed the issue for both server and currently monitoring the server and hosted websites which are working fine now.
Server: srv315.seekahost.net
Server: srv316.seekahost.net
Posted Jul 23, 2025 - 15:27 UTC

Investigating

We are currently investigating the issue on the server
Server: srv315.seekahost.net; Site Error - DNS_PROBE
Server: srv316.seekahost.net; Site Error - ERR_CONNECTION_REFUSED
Posted Jul 23, 2025 - 13:49 UTC
This incident affected: Seekahost.com (Hosting servcies).