313 - One of our Server Affected with DDOS Attack

Incident Report for SeekaHost

Resolved

IP Mitigation completed and issue has been resolved
Posted May 13, 2025 - 06:44 UTC

Monitoring

DDOS Attack on IP 139.99.255.61
Posted May 12, 2025 - 19:55 UTC
This incident affected: Seekahost.com (Hosting servcies).