Srv507 Server websites Down

Incident Report for SeekaHost

Resolved

The issue has been fixed. IP 142.44.227.247 is active now.
Posted Mar 17, 2026 - 03:45 UTC

Monitoring

Server IP 142.44.227.247 blocked on the network level. Currently under mitigation process.
Posted Mar 16, 2026 - 06:00 UTC

Investigating

We are currently investigating the issue.
Posted Mar 16, 2026 - 05:17 UTC