Anti - hack on 91.134.27.190

Incident Report for SeekaHost

Resolved

This incident has been resolved.
Posted May 18, 2025 - 06:03 UTC

Identified

Website under this IP - 91.134.27.190 will not work. Our server team is checking on the issue.
Posted May 17, 2025 - 16:42 UTC
This incident affected: Seekahost.com (Hosting servcies).