Srv329 Server Down

Incident Report for SeekaHost

Resolved

After Maintenance, the server boot issue fixed. Server back to normal. The websites and services are working smoothly.
Posted Mar 13, 2026 - 10:54 UTC

Investigating

We are currently investigating the issue.
Posted Mar 13, 2026 - 08:38 UTC
This incident affected: Seekahost.com (Hosting servcies).