DDOS Attack on IP 147.135.91.222

Incident Report for SeekaHost

Resolved

This incident has been resolved. IP and websites are accessible now.
Posted May 15, 2026 - 10:20 UTC

Monitoring

IP 147.135.91.222 is under mitigation due to an attack
Posted May 13, 2026 - 06:42 UTC
This incident affected: Seekahost.com (Hosting servcies).