SRV320

Incident Report for SeekaHost

Resolved

Mitigation has been completed for the IP address, and the services are back to normal.
Posted Sep 10, 2026 - 09:44 UTC

Identified

DDOS attack on IP 149.56.193.207
Posted Sep 09, 2026 - 15:43 UTC
This incident affected: Seekahost.com (Hosting servcies).