DDOS Attack

Incident Report for SeekaHost

Resolved

Our server team has fixed the issue and moved the IP back to the server, and has not found any downtime again. All websites are working fine.
Posted May 05, 2025 - 00:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 01, 2025 - 09:44 UTC

Identified

Particular IP - 139.99.255.137 has a DDoS attack, which is under mitigation
Posted May 01, 2025 - 09:20 UTC
This incident affected: Seekahost.com (Hosting servcies).