DDOS attack

Incident Report for SeekaHost

Resolved

The incident has been solved
Posted Jul 26, 2025 - 04:36 UTC

Monitoring

IP 94.23.95.92 has been identified as a DDoS attack, which is currently under mitigation.
Posted Jul 25, 2025 - 09:00 UTC
This incident affected: Seekahost.com (Hosting servcies).