Anti Hack

Incident Report for SeekaHost

Resolved

Our IP team has resolved the Issue now.
Posted Jul 19, 2025 - 10:15 UTC

Identified

Anti Hack on IP - 5.196.109.57 (malicious Activity)
Posted Jul 19, 2025 - 10:02 UTC
This incident affected: Seekahost.com (Class IP Hosting).