The server is up now. We are currently monitoring the server.
Posted May 01, 2025 - 16:12 UTC
Monitoring
It was found to be the issue with the Server Electric Connector & it is replaced now. The Issue is resolved and the server is currently under monitoring by our server team.
Posted May 01, 2025 - 15:53 UTC
Investigating
Currently, the 506 server is down, which our server team is investigating.
Posted May 01, 2025 - 15:40 UTC
This incident affected: Seekahost.co.uk (Hosting servcies).