DDOS attack

Incident Report for SeekaHost

Resolved

It is completely resolved now it's operational! Servers and websites are loading fine without any downtime.
Posted Aug 13, 2025 - 06:01 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 24, 2025 - 06:43 UTC

Monitoring

IP 193.70.66.162 has been identified as a DDoS attack, which is currently under mitigation.
Posted Jul 24, 2025 - 06:00 UTC
This incident affected: Seekahost.com (Hosting servcies).